Автор Тема: Что делать с гиф картинками в версии пхп их не поддерживающей?  (Прочитано 5008 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн giperborey

  • Завсегдатай
  • Новичок
  • *
  • Сообщений: 49
  • +0/-0
  • 0
    • Просмотр профиля
    • http://
С какой то версии пхп не поддерживает гиф формат... Но формат то распространенный...
Искомая фугкция уменьшение размера картинки после закачки...
Пока у меня фантазии хватило вместо уменьшеного гифа создать jpg c надписью - "нет уменьшеной версии"...
Как выйти из данной ситуации?

Оффлайн for_i_0

  • $15 per hour
  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 555
  • +0/-0
  • 2
    • Просмотр профиля
    • http://www.php.net/manual/en
giperborey
ПХП вообще не поддерживает какие там не были форматы изображений. Есть специальная библиотека которая работает с изображением и имя ей GD Library.

Далее цитирую новости из выше изложенного сайта:

 
Цитировать
07/21/04: gd 2.0.28 has been released. gd 2.0.28 restores support for reading and writing GIF images.
[off]Безработный[/off]

Оффлайн giperborey

  • Завсегдатай
  • Новичок
  • *
  • Сообщений: 49
  • +0/-0
  • 0
    • Просмотр профиля
    • http://
э... у меня с английским не очень...
насколько я понял с 28-й версии сохранили поддержку гифа...
а как бы ет ее установить?
я там на сайте что то скачал так вроде написано что для пхп не предназначено...
???

Оффлайн for_i_0

  • $15 per hour
  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 555
  • +0/-0
  • 2
    • Просмотр профиля
    • http://www.php.net/manual/en
Цитировать
giperborey: э... у меня с английским не очень...


[off]без комментариев[/off]

могу предложить очень хороший: GD Library FAQ на англ. языке. там приведены ответы на твои вопросы.

Поищи в поисковиках может что и найдешь на русcком.
« Последнее редактирование: 24 Февраля 2006, 22:31:47 от for_i_0 »
[off]Безработный[/off]

Оффлайн giperborey

  • Завсегдатай
  • Новичок
  • *
  • Сообщений: 49
  • +0/-0
  • 0
    • Просмотр профиля
    • http://
нашел некую длл... php_gd2.dll ток пишет что не найдена она...
на официальном сайте гд для пхп нет версии...
наверное легче установить пхп5 там наверняка гд поновее чем 28-я

Оффлайн Меняздесьдавнонет

  • новичЕк
  • Глобальный модератор
  • Ветеран
  • *****
  • Сообщений: 5698
  • +0/-0
  • 2
    • Просмотр профиля
    • http://
Цитировать
giperborey:
наверное легче установить пхп5 там наверняка гд поновее чем 28-я

молодец, соображаешь

Оффлайн giperborey

  • Завсегдатай
  • Новичок
  • *
  • Сообщений: 49
  • +0/-0
  • 0
    • Просмотр профиля
    • http://
насколько я понимаю для каждого дтстрибутива пхп имеется своя версия php_gd2.dll... которая  к более ранним версиям не подходит...
а интересно гд с вновь поддерживаемыми гифами в какой версии пхп появился?

 

Sitemap 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28